Back to overview
Degraded
DigitalOcean regional service degradation
Apr 30, 2026 at 10:01am UTC
Affected services
NYC1 - Compute
NYC1 - Event Processing
NYC1 - Functions
NYC1 - Kubernetes
Resolved
Apr 30, 2026 at 12:00pm UTC
DigitalOcean reports that the previously affected regional services have returned to normal operation.
Affected services
Created
Apr 30, 2026 at 10:01am UTC
DigitalOcean is reporting regional service degradation affecting NYC1. Impacted provider services currently include Droplets, Event Processing, Functions, Kubernetes. Nubis is monitoring the upstream provider and will post updates as recovery progresses.
Affected services