Back to overview
Degraded

DigitalOcean regional service degradation

May 4, 2026 at 1:00pm UTC
Affected services
SFO2 - Compute
SFO2 - Container Registry
SFO2 - Event Processing
SFO2 - Gpu Droplets
SFO2 - Kubernetes

Resolved
May 4, 2026 at 3:00pm UTC

DigitalOcean reports that the previously affected regional services have returned to normal operation.

Created
May 4, 2026 at 1:00pm UTC

DigitalOcean is reporting regional service degradation affecting SFO2. Impacted provider services currently include Container Registry, Droplets, Event Processing, Kubernetes. Nubis is monitoring the upstream provider and will post updates as recovery progresses.